ClassManifestDeprecatedApis

@deprecated("use scala.reflect.ClassTag instead", "2.10.0")
trait OptManifest[T]
class Object
trait Matchable
class Any
trait ClassTag[T]

Value members

Concrete methods

protected
def arrayClass[A](tp: Class[_]): Class[Array[A]]
override
def canEqual(other: Any): Boolean
Definition Classes
Source
ClassManifestDeprecatedApis.scala

Deprecated methods

@deprecated("use scala.reflect.runtime.universe.TypeTag for subtype checking instead", "2.10.0")
def <:<(that: ClassTag[_]): Boolean

Tests whether the type represented by this manifest is a subtype of the type represented by that manifest, subject to the limitations described in the header.

Tests whether the type represented by this manifest is a subtype of the type represented by that manifest, subject to the limitations described in the header.

Deprecated
Source
ClassManifestDeprecatedApis.scala
@deprecated("use scala.reflect.runtime.universe.TypeTag for subtype checking instead", "2.10.0")
def >:>(that: ClassTag[_]): Boolean

Tests whether the type represented by this manifest is a supertype of the type represented by that manifest, subject to the limitations described in the header.

Tests whether the type represented by this manifest is a supertype of the type represented by that manifest, subject to the limitations described in the header.

Deprecated
Source
ClassManifestDeprecatedApis.scala
@deprecated("use wrap instead", "2.10.0")
@deprecated("use runtimeClass instead", "2.10.0")
def erasure: Class[_]
@deprecated("use wrap.newArray instead", "2.10.0")
def newArray2(len: Int): Array[Array[T]]
@deprecated("use wrap.wrap.newArray instead", "2.10.0")
def newArray3(len: Int): Array[Array[Array[T]]]
@deprecated("use wrap.wrap.wrap.newArray instead", "2.10.0")
@deprecated("use wrap.wrap.wrap.wrap.newArray instead", "2.10.0")
@deprecated("use ArrayBuilder.make(this) instead", "2.10.0")
@deprecated("create WrappedArray directly instead", "2.10.0")
@deprecated("use scala.reflect.runtime.universe.TypeTag to capture type structure instead", "2.10.0")